Задать вопрос
12 июня, 14:28

Дано сначала число n, а затем n натуральных чисел, не превосходящих 100. Выведите на экран в порядке возрастания только те из них, которые встречаются в данной последовательности ровно один раз. На паскале АВС с использованием массива

+5
Ответы (1)
  1. 12 июня, 18:21
    0
    Var i, n, k:integer;

    a:array[1 ... 100] of integer;

    begin

    read (n) ;

    for i:=1 to n do

    a[i]:=0;

    for i:=1 to n do

    begin

    read (k) ;

    inc (a[k]) ;

    end;

    for i:=1 to 100 do

    if a[i]=1 then write (i,' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано сначала число n, а затем n натуральных чисел, не превосходящих 100. Выведите на экран в порядке возрастания только те из них, которые ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. В языке PHP создайте генератор случайного числа от 1 до 10. Выведите результат выполнения на экран любым способом. 2. Если полученное случайное число четное, выведите на экран слово "четное", иначе выведите на экран слово "нечетное". 3.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
С # 1. Создайте одномерный массив с 31 элементов, которые заполните случайными целыми числами от 11 до 100-11. Выведите значения элементов массива в строку, разделив их пробелами, 11 нечетное число.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Var day:byte; boy:string; pi:real; begin / / В блок памяти boy запишите Ваше имя / / В переменную day запишите Ваш возраст / / Выведите на экран содержимое переменной boy / / Выведите на середину экрана текст "Меня зовут", а рядом - содержимое
Ответы (1)