Задать вопрос
2 апреля, 09:40

Написать программу для сложения натуральных чисел А и В в троичной системе счисления

+1
Ответы (1)
  1. 2 апреля, 10:35
    0
    Function Is3Base (s:string) : Boolean;

    {

    Возвращает True, если строка представляет натуральное число

    в троичной системе счисления

    }

    const

    Dig3Base=['0' ... '2'];

    var

    i, n:integer;

    err:boolean;

    begin

    n:=Length (s) ;

    if n=0 then Is3Base:=False

    else begin

    i:=n;

    repeat

    err:=not (s[i] in Dig3Base) ;

    Dec (i) ;

    until (i=0) or err;

    Is3Base:=not err

    end

    end;

    procedure DigitsAlign (var s1, s2:string) ;

    {

    Дополняет слева нулями короткое слагаемое до длинного

    }

    var

    i, n, l1, l2:integer;

    begin

    l1:=Length (s1) ; l2:=Length (s2) ;

    if l1>l2 then

    for i:=l2+1 to l1 do s2:='0'+s2

    else

    for i:=l1+1 to l2 do s1:='0'+s1

    end;

    function Add3Base (s1, s2:string) : string;

    {

    Сложение на строках натуральных чмсел s1 и s2

    в системе счисления по основанию 3

    }

    var

    s:string;

    c0, i, ip, d:integer;

    begin

    c0:=Ord ('0') ;

    If not Is3Base (s1) then Add3Base:=s1+' не троичное'

    else

    if not Is3Base (s2) then Add3Base:=s2+' не троичное'

    else begin

    DigitsAlign (s1, s2) ;

    ip:=0; s:='';

    for i:=Length (s1) downto 1 do begin

    d:=Ord (s1[i]) + Ord (s2[i]) - 2*c0+ip;

    if d>2 then begin ip:=1; d:=d-3 end

    else ip:=0;

    s:=Chr (d+c0) + s

    end;

    if ip=1 then s:='1'+s;

    Add3Base:=s

    end

    end;

    var

    s1, s2, sr:string;

    begin

    Write ('Введите первое слагаемое в троичной системе: ') ;

    Readln (s1) ;

    Write ('Введите второе слагаемое в троичной системе: ') ;

    Readln (s2) ;

    Writeln (s1,' (3) + ', s2,' (3) = ', Add3Base (s1, s2),' (3) ')

    end.

    Тестовое решение:

    Введите первое слагаемое в троичной системе: 12101120122001

    Введите второе слагаемое в троичной системе: 10020021122

    12101120122001 (3) + 10020021122 (3) = 12111210220200 (3)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу для сложения натуральных чисел А и В в троичной системе счисления ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
А) 1000001110 в двоичной системе счисления+1100110 в двоичной системе счисления б) 10001001 в двоичной системе счисления-1010101 в двоичной системе счисления в) 45 в восьмеричной системе счисления * 71 в восьмеричной системе счисления г) 1AF1 в
Ответы (1)
1) Десятичное число 4563 в двоичной системе счисления равно 2) Десятичное число 800 в восьмеричной системе счисления равно 3) Десятичное число 781 в шестнадцатеричной системе счисления равно 4) Двоичное число 1000000 в десятичной системе счисления
Ответы (1)
Выполните сложение: а) 1153 в 8 системе счисления + 1147 в 8 системе счисления. б) 4DFв 16 системе счисления + 160 в 16 системе счисления. в) 1110101010 в 2 системе счисления + 10111001 в 2 системе счисления.
Ответы (1)
1. Выполните сложение в двоичной системе счисления: 101112 + 1011102 Результат запишите в двоичной системе счисления. 2. Выполните сложение в двоичной системе счисления: 11012 + 110112 Запишите ответ в двоичной системе счисления.
Ответы (1)
1. Запишите число 156 в шестнадцатеричной системе счисления. 2. Запишите число AD16 В десятичной системе счисления. 3. Запишите число 111100000012 в шестнадцатеричной системе счисления. 4. Запишите число 125 В 16 В двоичной системе счисления. 5.
Ответы (1)