Задать вопрос
24 марта, 16:19

На языке Паскаля. Составе программу, которая вводится с клавиатуры последовательность из пяти висели после ввода каждого числа выводят среднее арифметическое полученной части последовательности.

+5
Ответы (2)
  1. 24 марта, 17:59
    0
    Var i:byte;

    n, k:real;

    begin

    for i:=1 to 5 do

    begin

    readln (n) ;

    k:=k+n;

    writeln (k/i) ;

    end;

    end.
  2. 24 марта, 19:46
    0
    Program sum_41;

    var a, b, c, d, e: real;

    begin

    readlan (a) ;

    writeln (a/1) ;

    readln (b) ;

    writeln ((a+b) / 2) ;

    readln (c) ;

    writeln ((a+b+c) / 3) ;

    readln (d) ;

    writeln ((a+b+c+d) / 4) ;

    readln (e) ;

    writeln ((a+b+c+d+e) / 5) ;

    end.

    Как-то так
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «На языке Паскаля. Составе программу, которая вводится с клавиатуры последовательность из пяти висели после ввода каждого числа выводят ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу на языке Паскаль для следующих задач: 1. Найдите сумму всех чисел от a до 500 (значение a вводится с клавиатуры; a≤500). 2. Найдите среднее арифметическое всех целых чисел от a до b (значение a и b вводится с клавиатуры; a≤b). 3.
Ответы (1)
1. Переключение клавиатуры с режима ввода латинских букв на режим ввода русских букв и обратно? 2. переключение клавиатуры с режима ввода строчных букв на режим ввода прописных букв и обратно? 3.
Ответы (1)
Помогите решить через паскаль 1) массив А вводится с клавиатуры, найти среднее арифметическое его элементов с нечетными номерами, размер произвольный.
Ответы (1)
1. Вводится не менее восьми чисел. Конец ввода 0. Найти сумму первых пяти чисел и произведение последних пяти чисел. Составить блок-схему и программу к задаче. 2. Вводится текст. Конец ввода F4. Найти количество букв.
Ответы (1)
Разобрать прошрамму, которая вводит с клавиатуры последовательность из M дробных чисел и после ввода каждого числа выводит сумму и среднее арифметическое введенной части последовательности
Ответы (1)