Задать вопрос
1 ноября, 11:43

Если число заканчивается на 2 или 3, то исходное число умножить на число десятков в нем, если число единиц от 7 до 9, то из числа вычесть сумму цифр числа, в противном случае отбросить последнюю цифру.

Pascal

+4
Ответы (1)
  1. 1 ноября, 11:56
    0
    Function summ (a:integer) : integer;

    begin

    while (a0) do begin

    summ+=a mod 10;

    a:=a div 10;

    end;

    end;

    var a:integer;

    begin

    read (a) ;

    if (a mod 10 = 2) or (a mod 10 = 3) then a * = (a div 10) mod 10

    else if (a mod 10 > = 7) and (a mod 10 < = 9) then a-=summ (a)

    else a:=a div 10;

    writeln (a) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Если число заканчивается на 2 или 3, то исходное число умножить на число десятков в нем, если число единиц от 7 до 9, то из числа вычесть ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу на паскале, которая 1) сначала определит по введенному двузначному числу цифру десятков и цифру единиц. 2.1) Если цифра десятков меньше цифры единиц, то программа выведет двузначное число, состоящее из. цифр единиц.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Запишите команды, с помощью которых можно: 1) записать в переменную d последнюю цифру числа, находящегося в переменной N; 2) отбросить последнюю цифру числа, находящегося в переменной N;
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Помогите написать программу на Pascal Из трехзначного числа X вычли его последнюю цифру. Когда результат разделили на 10, а к частному слева приписали последнюю цифру числа X. То получилось число N.
Ответы (1)