Задать вопрос
2 марта, 18:38

Pascal.

1. Определить количество слов в предложении.

2. Определить какая буква в строке встречается чаще: первая или последняя.

3. Написать программу меняющую слово "Петр" на "Иван".

+1
Ответы (1)
  1. 2 марта, 20:06
    0
    Для подсчёта слов в предложении, вот код:

    program Slova;

    var

    s: string;

    r, i:integer;

    begin

    writeln ('Введите ваше предложение') ;

    readln (s) ;

    s:=s+' ';

    for i:=1 to length (s) - 1 do

    if (s' ') and (s[i+1]=' ') then

    r:=r+1;

    writeln ('В предложении ', r, ' слов. ') ;

    readln;

    end.

    Какая буква встречается чаще

    Program Bykv;

    Var s:String;

    i, k1, k2:byte;

    Begin

    write ('Введите строку: ') ; readln (s) ;

    For i:=2 to Length (s) - 1 do

    if s[i]=s[1] then inc (k1)

    else if s[i]=s[Length (s) ] then inc (k2) ;

    writeln ('Первая буква встречается ', k1) ;

    writeln ('Последняя буква встречается ', k2) ;

    writeln ('Вывод:') ;

    if k1>k2 then writeln ('Первая буква встречается чаще')

    else if k1
    writeln ('Последняя буква чаще')

    else writeln ('Одинаково') ;

    readln;

    End.

    Изменить слово петя на иван в строке

    program test;

    var s, t, z, p:string; j:integer;

    begin

    writeln ('Введите ваше предложение') ;

    readln (s) ;

    write ('Введите слово которое хотите заменить: ') ;

    readln (t) ;

    write ('Введите замену слову: ', t, ' ') ;

    readln (z) ;

    if pos (t, s) 0 then

    j:=pos (t, s) ;

    p:=copy (s, 1, j-1) ;

    p:=p+z;

    p:=p+copy (s, j+length (t), length (s)) ;

    writeln (p) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal. 1. Определить количество слов в предложении. 2. Определить какая буква в строке встречается чаще: первая или последняя. 3. Написать ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Какие из слов удовлетворяют следующему условию: (первая буква согласная->последняя буква согласная) U (первая буква гласная->последняя буква гласная) спорт клавиатура аэропорт яблоня буква
Ответы (2)
Какое из приведённых имён удовлетворяет логическому условию: (первая буква гласная И последняя буква согласная) ИЛИ (первая буква согласная И последняя буква гласная) ? Если таких слов несколько, укажите самое короткое из них: a. Антон b. Сережа c.
Ответы (1)
Какое из приведённых имён удовлетворяет логическому условию: (первая буква согласная ИЛИ последняя буква согласная) И НЕ (последняя буква согласная) ? Если таких слов несколько, укажите самое длинное из них. Выберите один ответ: a. Иван b. Таня c.
Ответы (1)
Какое из приведённых имён удовлетворяет логическому условию: (первая буква согласная И последняя буква согласная) ИЛИ НЕ (последняя буква согласная) ? Если таких слов несколько, укажите самое длинное из них Выберите один ответ: a. Иван b. Марина c.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)