Задать вопрос
11 ноября, 20:00

Как найти первые две цифры натурального числа в паскале?

+4
Ответы (2)
  1. 11 ноября, 20:16
    0
    Var

    n:longint;

    i, d:integer;

    begin

    ClrScr;

    Write ('n=') ; Read (n) ;

    if n<100 then Writeln (n:2)

    else begin

    repeat

    n:=n div 10;

    if n<100 then Writeln (n:2)

    until n<=99;

    end;

    Readkey

    end.
  2. 11 ноября, 20:56
    0
    Program al;

    var n:integer;

    begin

    writeln ('n=') ;

    readln (n) ;

    if (n >9) and (n<100) then writeln (n) ;

    if (n > 99) and (n<1000) then writeln (n div 10) ;

    if (n >1000) and (n<10000) then writeln (n div 100) ;

    if n>10000 then writeln (n div 1000) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Как найти первые две цифры натурального числа в паскале? ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Задача в паскале. Вывести на экран в порядке возрастания все цифры, не являющиеся цифрами данного десятичного натурального числа (переменной целого типа). Например, число 125657 не содержит цифры: 0, 3, 4, 8, 9.
Ответы (1)
1) найти количесво делителей натурального числа, сколько из них чётных? 2) дано натуральное число: найти две первые цыфры числа верно ли, что первая цыфраа данного числа чётная?
Ответы (1)
Найдите натуральное число такое что его запись в семеричной системе счисления имеет ровно четыре значащих разряда и при этом выполняются следующие условия: Две первые цифры его записи являются одинаковыми между собой и две последние цифры также
Ответы (1)
Помогите решить задачу по информатике в паскале! Программа определения цифры десятков натурального числа
Ответы (1)