Задать вопрос
25 июля, 12:53

Решить в Pascal:

Найти произведение, сомножители которого представлены каждым третьим членом: X1, X4, X7, и т. д. - заданного массива X1, X2, ..., Xn.

+3
Ответы (1)
  1. 25 июля, 13:32
    0
    Var a: array [1 ... 200] of integer;

    i, j, q, a1: integer;

    begin

    Writeln ('Kakoi dlini massiv?') ;

    Readln (q) ;

    for i:=1 to q doReadln (a[i]) ;

    a1:=a[1];

    j:=1;

    while j<=q do

    beginj:=j+3;

    a1:=a1*a[j];

    end;

    Writeln (a1) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решить в Pascal: Найти произведение, сомножители которого представлены каждым третьим членом: X1, X4, X7, и т. д. - заданного массива X1, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Помогите с информатикой 1. Что такое массив? 2. Что такое элемент массива? 3. Что такое индекс массива? 4. Что такое размерность массива? 5. Зачем нужны массивы? 6. Как можно обратиться к ячейке массива? 7. Какого типа могут быль элементы массива? 8.
Ответы (1)
Написать программу, позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива. Длина массива N задается пользователем как константное выражение.
Ответы (1)