Задать вопрос
19 апреля, 20:34

Вариант А

1) Опишите, что выполняет данная программа. Приведите пример на конкретных числах:

var a, b, s, j:integer;

begin

read (a, b) ;

s:=0;

for j:=a to b do

begin

s:=s+j;

end;

write (s) ;

end.

2) Напишите программу, которая выводит все четные числа до заданного пользователем числа.

+3
Ответы (1)
  1. 19 апреля, 22:01
    0
    1) Программа находит сумму всех чисел от a до b. Например для 3 и 5, она выведет 12

    2)

    var

    a, i:integer;

    begin

    read (a) ;

    for i : = 1 to a do

    if i mod 2 = 0 then

    write (i, ' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вариант А 1) Опишите, что выполняет данная программа. Приведите пример на конкретных числах: var a, b, s, j:integer; begin read (a, b) ; ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы