Задать вопрос
25 марта, 01:02

Найдите сумму элементов одномерного массива, состоящего из 10 элементов.

разделите каждый элемент исходного массива на полученное значение.

результат получите в том же массиве. результат вывести в одной строке

+5
Ответы (1)
  1. 25 марта, 02:36
    0
    Program z4;

    var mas:array[1 ... 10] of real;

    var s:real;

    var i:integer;

    begin

    s:=0;

    for i:=1 to 10 do

    begin

    write ('Введите ', i,' число: ') ;

    readln (mas[i]) ;

    s:=s+mas[i];

    end;

    writeln ('Новый массив: ') ;

    for i:=1 to 10 do

    begin

    mas[i]:=mas[i]/s;

    write (mas[i],' ') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найдите сумму элементов одномерного массива, состоящего из 10 элементов. разделите каждый элемент исходного массива на полученное значение. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделать программу в Pascal. 1. Организуйте ввод и вывод одномерного массива в строку, в столбец. 2. Найдите произведение ненулевых элементов одномерного массива. 3.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Паскаль! Дан массив А размерностью N. Записать в каждый элемент массива В следующие значения: 1 ый элемент - сумма всех нечетных элементов массива А; 2 ои элемент - сумма всех четных элементов массива А: Зий элемент - сумма всех элементов массива А
Ответы (1)
Заменить значение каждого элемента каждой строки массива А на значение соответствующего элемента соответствующего столбца массива В (1-й элемент 1-й строки массива А на 1-й элемент 1-го столбца массива В, 2-й элемент 1-й строки массива А на 2-й
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)