Задать вопрос
26 февраля, 19:37

Чему будет равно значение переменной j после выполнения следующей последовательности операторов?

i:=3;

if abs (i-3) >2 then

j:=sqr (i+3) mod 4

else

j: = (i+1) div 3;

+3
Ответы (1)
  1. 26 февраля, 21:57
    0
    J=4 div3 4 разделить нацело на 3

    верный ответ

    j=1
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Чему будет равно значение переменной j после выполнения следующей последовательности операторов? i:=3; if abs (i-3) >2 then j:=sqr (i+3) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. определить значение переменной А после выполнения оператора X:=5; if X>-3 then A:=X mod 2 else A:=abs (X) ; 2. определить значение переменной А после выполнения оператора X:=-26; Y:=6; if X div Y=4 then A:=X mod Y else A:=X*Y; 3.
Ответы (1)
Определить значение выражения: 1) 10 div 15 2) 10 div 2 3) 10 mod 2 4) 10 mod 17 5) 123 mod 10 6) 123 div 10 7) 1 div 2 8) 123 mod 1000 9) 100 mod 27 div 3 10) 100 div 5 mod 3 11) 98725 div 1000 mod 10 12) 100 mod 5 div 3
Ответы (1)
Тест: Операторы целочисленной арифметики div и mod 1. Вычислите: 25 div 11 2.27 3 2 2. Вычислите: 64 div 9 1 7 6 3. Вычислите: (35 div 2) div 5 2 17 3 4. Вычислите: (78 div 5) mod 10 5 15 10 5. Вычислите: (25 mod 11) + (18 mod 7) 3 7 4 6.
Ответы (1)
1. Решите примеры 13 div 5 = 13 mod 5 = 5 div 5 = 5 mod 5 = 3 div 8 = 3 mod 8 = 10 div 6 mod 3 = 2. Определите результат выполнения следующих действий а) a:=1819; b: = (div (а, 100)) * 10 + 9 a: = mod (10*b - a),100) а = ? b = ?
Ответы (1)
Почему не выдает числа? uses crt; var i:integer; begin for i: = 100 to 999 do if i = ((sqr (i div 100) * (i div 100)) + ((sqr (i div 10) mod 10) * (i div 10) mod 10) + (sqr (i mod 10) * i mod 10)) then writeln (i) ; end.
Ответы (1)