Задать вопрос
13 декабря, 05:33

Написать программу, которая осуществляет вывод одномерного массива, поиск максимального значения и выводит его индекс в этом массиве.

+1
Ответы (1)
  1. 13 декабря, 07:19
    0
    Var i, imax, amax:integer;

    a:array[1 ... 10] of integer;

    begin

    writeln ('Введите числа') ;

    for i:=1 to 10 do

    begin

    write ('a[', i,'] = ') ;

    read (a[i]) ;

    end;

    a[1]:=amax;

    imax:=1;

    for i:=1 to 10 do

    if amax
    begin

    amax:=a[i];

    imax:=i;

    end;

    writeln ('Исходный массив') ;

    for i:=1 to 10 do

    write (a[i]:4) ;

    writeln;

    writeln ('Элемент под номером ', imax,' имеет максимальное значение равное ', amax) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, которая осуществляет вывод одномерного массива, поиск максимального значения и выводит его индекс в этом массиве. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сравните. P. S. напишите решение а) 285 (индекс 10) и 11D (индекс 16) б) 111111 (индекс 2) и 1111 (индекс 8) в) 6 С (индекс 16) и 101001 (индекс 2) г) 55 (индекс 16) и 125 (индекс 8)
Ответы (1)
Сделать программу в Pascal. 1. Организуйте ввод и вывод одномерного массива в строку, в столбец. 2. Найдите произведение ненулевых элементов одномерного массива. 3.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)
Помогите с информатикой 1. Что такое массив? 2. Что такое элемент массива? 3. Что такое индекс массива? 4. Что такое размерность массива? 5. Зачем нужны массивы? 6. Как можно обратиться к ячейке массива? 7. Какого типа могут быль элементы массива? 8.
Ответы (1)