Задать вопрос
24 января, 09:42

Напишите программу, которая переводит десятичные числа в эквиваленты из соответствующих систем счисления по основанию b, 10 > b < = 36.

+5
Ответы (1)
  1. 24 января, 12:24
    0
    Var i, k, j, n, ost, p:integer;

    x, s:string;

    begin

    read (s) ;

    n:=strtoint (s) ;

    for j:=11 to 36 do

    begin

    x:='';

    p:=n;

    k:=0;

    while p0 do

    begin

    ost:=p - (p div j) * j;

    p:=p div j;

    k:=k+1;

    if (ost >9) and (ost <=36) then

    x:=chr (ost+55) + x

    else

    x:=inttostr (ost) + x;

    end;;

    writeln (x,' ', j,' ss') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая переводит десятичные числа в эквиваленты из соответствующих систем счисления по основанию b, 10 > b < = 36. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Вычислить выражения: а) 5 по основанию 8 + 4 по основанию 8 б) 17 по основанию 8 + 41 по основанию 8 в) F по основанию 16 - A по основанию 16 г) 41 по основанию 16 - 17 по основанию 16
Ответы (1)
А) 1000001110 в двоичной системе счисления+1100110 в двоичной системе счисления б) 10001001 в двоичной системе счисления-1010101 в двоичной системе счисления в) 45 в восьмеричной системе счисления * 71 в восьмеричной системе счисления г) 1AF1 в
Ответы (1)
1) Десятичное число 4563 в двоичной системе счисления равно 2) Десятичное число 800 в восьмеричной системе счисления равно 3) Десятичное число 781 в шестнадцатеричной системе счисления равно 4) Двоичное число 1000000 в десятичной системе счисления
Ответы (1)
1. Выполните сложение в двоичной системе счисления: 101112 + 1011102 Результат запишите в двоичной системе счисления. 2. Выполните сложение в двоичной системе счисления: 11012 + 110112 Запишите ответ в двоичной системе счисления.
Ответы (1)
Выполните сложение: а) 1153 в 8 системе счисления + 1147 в 8 системе счисления. б) 4DFв 16 системе счисления + 160 в 16 системе счисления. в) 1110101010 в 2 системе счисления + 10111001 в 2 системе счисления.
Ответы (1)