Задать вопрос
16 июля, 21:49

Даны координаты двух точек (х1 у1) и (х2 у2) вывести сообщение о том находятся ли точки в одной координатной четвери (паскаль if).

+5
Ответы (1)
  1. 17 июля, 00:26
    0
    { Если в Вашей версии система "ругается" на sign, раскомментируйте

    текст определения этой функции. В противном случае удалите все комментарии }

    {

    function sign (x:real) : integer;

    begin

    if x<0 then sign:=-1

    else

    if x>0 then sign:=1 else sign:=0

    end;

    }

    var

    x1, x2, y1, y2:real;

    begin;

    Write ('Введите через пробел координаты точки 1: ') ;

    Read (x1, y1) ;

    Write ('Введите через пробел координаты точки 2: ') ;

    Read (x2, y2) ;

    if (sign (x1) = sign (x2)) and (sign (y1) = sign (y2))

    then Writeln ('Точки находятся в одной четверти')

    else Writeln ('Точки находятся в разных четвертях')

    end.

    Тестовое решение:

    Введите через пробел координаты точки 1: - 3.5 8.1

    Введите через пробел координаты точки 2: - 5 4

    Точки находятся в одной четверти
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны координаты двух точек (х1 у1) и (х2 у2) вывести сообщение о том находятся ли точки в одной координатной четвери (паскаль if). ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Даны координаты двух точек на плоскости, требуется определить, лежат ли они в одной координатной четверти или нет. (На Паскале) Входные данные Вводятся 4 числа: координаты первой точки (x1, y1) и координаты второй точки (x2, y2).
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)