Задать вопрос
4 марта, 15:36

Написать программу на Паскале, которая выведет на экран те строки из текстового файла, которые являются палиндромами. Имя файла вводить с клавиатуры.

+5
Ответы (1)
  1. 4 марта, 19:29
    0
    Program proga_25_3;

    var

    A: text;

    s, p : string;

    i:integer;

    f:boolean;

    begin

    write ('Введите имя и путь к файлу ') ;

    read (p) ;

    assign (A, p) ;

    reset (A) ;

    while not eof (A) do

    begin

    readln (A, s) ;

    for i:=1 to length (s) div 2 do

    if s[i]=s[length (s) - i+1] then

    f:=true

    else

    begin

    f:=false;

    break;

    end;

    if f then

    writeln (S) ;

    end;

    close (A) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на Паскале, которая выведет на экран те строки из текстового файла, которые являются палиндромами. Имя файла вводить с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать программу, которая запрашивает имя файла и распечатывает из него только те строки, которые являются палиндромами (python)
Ответы (1)
Написать программу, которая позволяет просматривать текстовые файлы (выводит на экран содержимое файла), например, файлы исходных программ Turbo Pascal. Имя просматриваемого файла должно вводится во время работы программы.
Ответы (1)
В базе данных с атрибутами Имя файла, Размер, Дата изменения имеется запись со значениями Имя файла = "PR1. TXT", Размер = 156 Кb, Дата изменения = 25.06.06. Эта запись удовлетворяет условиям запросов: 1) (Имя файла / = "PR1.
Ответы (1)
Имя входного файла:E. in имя выходного файла E. out Дается ... Имя входного файла:E. in имя выходного файла E. out Дается последовательность из N чисел. найдите максимальное произ. среди всех пар этих чисел.
Ответы (1)
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)