Задать вопрос
12 апреля, 09:52

Определите значение переменной X после выполнения фрагментов программ:

1) for i:=0 to 5 do x : = i

2) for i:=5 downto 0 do x:=i

3) for i:=1 to 3 do x:=i*2

4) for i:=1 to 5 do x:=i*2-1

A. 0

B. 5

C. 9

D. 6

+2
Ответы (1)
  1. 12 апреля, 12:22
    0
    В первом х принимает значение 0;

    Во втором х принимает значение 5;

    В третьем х принимает значение 6;

    В четвертом х принимает значение 9.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определите значение переменной X после выполнения фрагментов программ: 1) for i:=0 to 5 do x : = i 2) for i:=5 downto 0 do x:=i 3) for i:=1 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
3. Чему будет равно значение целой переменной a после выполнения этого фрагмента программы? a:=2; for i:=0 to 2 do begin a:=a+i; end; Ответ: введите число 4.
Ответы (2)
1. Определить сколько раз выполнится цикл 1) For i:=2 to 3 do k:=k-1; 2) For i:=9 to 7 do k:=k+1; 3) For i:=5 to 2 do k:=k-1; 4) For i:=15 downto 4 do k:=k-1; 5) For i:=8 downto 10 do k:=k*10; 6) For i:=5 downto 3 do k:=т+3;
Ответы (1)
Сколько раз выполнится тело цикла? 1) For x:=3 to 8 do write ('*') ; 2) For x:=1 to 1 do write ('*') ; 3) For x:=5 to 3 do write ('*') ; 4) For x:=7 downto 4 do write ('*') ; 5) For x:=2 downto 2 do write ('*') ; 6) For x:=4 downto 9 do write ('*') ;
Ответы (1)
1. определить значение переменной А после выполнения оператора X:=5; if X>-3 then A:=X mod 2 else A:=abs (X) ; 2. определить значение переменной А после выполнения оператора X:=-26; Y:=6; if X div Y=4 then A:=X mod Y else A:=X*Y; 3.
Ответы (1)
Запишите на алгоритмическом языке алгоритм, в результате которого переменной A будет присвоено значение переменной B, переменной B-значение переменной C, а переменной C-значение переменной A. Используйте не более одной промежуточной переменной.
Ответы (1)