Задать вопрос
6 октября, 01:32

Pascal. НЕобходимо разобрать перед экзаменом.

С клавиатуры вводится последовательность n (n - количество) натуральных чисел. Определить наименьшее тех из них, у которых пред последняя цифра 8.

Мне нужна готовая работающая программа для Паскаля, словесно ответ и так знаю.

+5
Ответы (1)
  1. 6 октября, 04:32
    0
    Var

    d, min, i, n: integer;

    begin

    write ('Введите N=') ;

    readln (n) ;

    write ('Введите число ') ;

    readln (d) ;

    min : = d;

    for i : = 2 to n do

    begin

    write ('Введите следующее число ') ;

    readln (d) ;

    if (d mod 100 div 10 = 8) and ((min mod 100 div 10 8) or (min > d)) then

    min : = d;

    end;

    if (min mod 100 div 10 8) then

    writeln ('Не найдено')

    else

    writeln (min) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal. НЕобходимо разобрать перед экзаменом. С клавиатуры вводится последовательность n (n - количество) натуральных чисел. Определить ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Написать программу для Паскаля: Дата вводится в формате "дд. мм. гг". Записать словесно название месяца и полностью указать год. Например, для 01.02.98 вывести "1 февраля тысяча девятьсот девяносто восьмой год", для 20.05.
Ответы (1)
Я никогда не подружусь с этой темой ... 1. С клавиатуры вводится 7 целых чисел. Найти сумму всех нечетных среди них. 2. С клавиатуры вводится 7 целых чисел. Найти произведение чисел кратных 7. (Информатика. Тема: Pascal ABC. 8 класс)
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)