Задать вопрос
16 марта, 22:22

Даны 2 одномерных массива 1-ый из n, 2-ой из m элементов. В каждом массиве найти min элемент и поменять с первым элементом этого массива.

+4
Ответы (1)
  1. 17 марта, 01:09
    0
    Int mass1[n], mass2[m];

    int min = 0, buff = 0, index;

    //сначала находим min элемент

    for (int i = 1; i < n; i++)

    {

    if (mass1[i - 1] > mass1[i])

    {

    min = mass1[i];

    index = i;

    }

    }

    //меняем их местами

    buff = mass1[0];

    mass1[0] = min;

    mass1[index] = buff;

    //ищем min во втором массиве

    for (int i = 1; i < n; i++)

    {

    if (mass2[i - 1] > mass2[i])

    {

    min = mass2[i];

    index = i;

    }

    }

    //меняем их местами

    buff = mass2[0];

    mass2[0] = min;

    mass2[index] = buff;

    ну а дальше с библиотеками и выводом я думаю сам додумаешь)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны 2 одномерных массива 1-ый из n, 2-ой из m элементов. В каждом массиве найти min элемент и поменять с первым элементом этого массива. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Program naim4; var a, b, c, d, min:real; begin; writeln ('введите 4 числа') ; readln; min:=a; if b < min then min:=b; if c < min then min:=c; if d < min then min:=d; writeln ('минимальное ', min) ; readln; end.
Ответы (2)
5. Нахождение минимального числа из введенных. Program MIN; Var A, I : Integer; Min : Integer; Begin Min:=32767; For I:=1 to 10 do Begin Write ('Vvedi chislo ') ; Readln (A) ; If A < Min then Min:=A; end; Writeln ('MIN=', Min) ; Readln; end.
Ответы (1)
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Создать два одномерных массива, состоящих из целых чисел. Элементы массива вводятся с клавиатуры. В первом массиве найти номер первого нечетного элемента массива. Во втором массиве найти первый четный элемент массива.
Ответы (1)