Задать вопрос
31 июля, 17:52

Известно, что Дима купил 12 воздушных шариков за 12 рублей. Среди купленных шаров были шары желтого, красного и зеленого цветов. Какое количество желтых, красных и зеленых шаров было куплено Димой, если желтый шар стоит полрубля, красный полтора рубля, а зеленый два рубля?

В ответе укажите количество желтых, красных и зеленых шаров соответственно, записав в поле ответа только числа через один пробел без каких-либо знаков препинаний, например, 9 4 2

+2
Ответы (1)
  1. 31 июля, 21:44
    0
    Желтые Красные Зеленые

    6 6 0

    8 0 4

    7 3 2

    Вот программка на Паскале:

    uses Crt;

    var g, k, z:integer;

    begin

    ClrScr;

    for g:=0 to 12 do

    for k:=0 to 12 do

    for z:=0 to 12 do

    begin

    if (g+k+z=12) and (0.5*g+1.5*k+2*z=12) then

    WriteLn (g,' ', k, ' ', z) ;

    end;

    ReadLn;

    end.

    Вывод: Можно вообще не брать красные или зеленые шары.

    Если брать шары всех цветов, то ответ у задачи один

    7 3 2
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Известно, что Дима купил 12 воздушных шариков за 12 рублей. Среди купленных шаров были шары желтого, красного и зеленого цветов. Какое ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
У Пятачка была очень большая коллекция воздушных шариков разных цветов. M воздушных шариков содержали красный цвет, N - зелёный и K - синий.
Ответы (1)
Цвет точки на экране дисплея с 16-цветной палитрой формируется из сигналов: а) красного зелёного и синего. б) красного зелёного синего и яркости. в) желтого зелёного синего и красного. г) жёлтого синего красного и яркости
Ответы (1)
У меня есть три карандаша: жёлтый, зелёный и фиолетовый. Назовите самый короткий и самый длинный из карандашей, если известно, что: а) фиолетовый карандаш короче жёлтого, а жёлтый короче зелёного, в) жёлтый карандаш длиннее фиолетового, а фиолетовый
Ответы (1)
Известно, что в ящике лежат 10 чёрных шаров, 5 белых, 4 жёлтых и 1 красный. Какое количество информации несут сообщения о том, что из ящика случайным образом достали чёрный шар, белый шар, жёлтый шар, красный шар?
Ответы (1)
Помогите решить задачу по информатике У Чебурашки есть игрушки. Цвет игрушки Автомобиль Красный Зелёный Медвежонок Красный Зелёный Синий Жёлтый Мяч Синий Жёлтый Красный Он хочет выбрать из этих игрушек один автомобиль ...
Ответы (1)