Задать вопрос
29 июля, 17:19

Написать программу. Даны 2 числа a и b. Найти среднее арифметическое всех чисел кратных 3 из интервала [a, b].

+1
Ответы (1)
  1. 29 июля, 18:50
    0
    var

    i, j, a, b: integer;

    s: real;

    begin

    write ('Введите a: ') ; readln (a) ;

    write ('Введите b: ') ; readln (b) ;

    for i : = a to b do

    if (i mod 3) = 0 then

    begin

    s : = s + i;

    inc (j) ;

    end;

    s : = s / j;

    writeln ('Ответ: ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу. Даны 2 числа a и b. Найти среднее арифметическое всех чисел кратных 3 из интервала [a, b]. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача № 2. Сумма нечетных чисел Вычислить сумму всех нечетных чисел из интервала [a, b]. Например, сумма нечетных чисел из интервала [3, 9] равна 3 + 5 + 7 + 9 = 24.
Ответы (1)
Напишите программу, которая в последовательности целых чисел находит среднее арифметическое чисел, кратных 9, или сообщает, что таких чисел нет.
Ответы (1)
20.2 (№ 987) Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое чисел, кратных 8, или сообщает, что таких чисел нет (выводит "NO").
Ответы (1)
Задачи на записи и файлы. № 1. Пусть дан файл целых чисел. Определите длину наибольшего интервала возрастания и среднее арифметическое чисел этого интервала. № 2. Имеется типизированный файл с числами.
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)