Задать вопрос
11 марта, 13:27

Составьте программу вычисления суммы тех элементов одномерного массива A (N), что одновременно встречаются в массиве B (N)

+3
Ответы (1)
  1. 11 марта, 14:26
    0
    Const nmax=100;

    var a, b:array[1 ... nmax] of integer;

    i, j, n1, n2, s:integer;

    p:boolean;

    begin

    randomize;

    repeat

    write ('Размер массива A = ') ;

    readln (n1) ;

    until n1 in [1 ... nmax];

    writeln;

    writeln ('Массив A: ') ;

    for i:=1 to n1 do

    begin

    a[i]:=random (15) ;

    write (a[i],' ') ;

    end;

    writeln;

    writeln;

    repeat

    write ('Размер массива B = ') ;

    readln (n2) ;

    until n2 in [1 ... nmax];

    writeln;

    writeln ('Массив B: ') ;

    for i:=1 to n2 do

    begin

    b[i]:=random (15) ;

    write (b[i], ' ') ;

    end;

    s:=0;

    for i:=1 to n1 do

    begin

    p:=false;

    j:=1;

    while (j<=n2) and not p do

    if b[j]=a[i] then p:=true

    else

    inc (j) ;

    if p then inc (s, a[i]) ;

    end;

    writeln;

    writeln;

    writeln ('Сумма = ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу вычисления суммы тех элементов одномерного массива A (N), что одновременно встречаются в массиве B (N) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделать программу в Pascal. 1. Организуйте ввод и вывод одномерного массива в строку, в столбец. 2. Найдите произведение ненулевых элементов одномерного массива. 3.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Написать программу, позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива. Длина массива N задается пользователем как константное выражение.
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)