Задать вопрос
21 мая, 11:32

Напишите программу, которая инвертирует определенный бит в заданном числе (биты при этом нумеруются с 0, начиная с младших).

+1
Ответы (1)
  1. 21 мая, 13:54
    0
    Var

    n, k:integer;

    begin

    Write ('Укажите число и номер инвертируемого бита: ') ;

    Read (n, k) ;

    Writeln ('Результат: ', n xor (1 shl k))

    end.

    Тестовое решение:

    Укажите число и номер инвертируемого бита: 573 4

    Результат: 557
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая инвертирует определенный бит в заданном числе (биты при этом нумеруются с 0, начиная с младших). ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Выполните перевод. a) 37 Кбайт 515 Байт 3 бит в биты. b) 3 Кбайт в биты. c) 1 Мбайт в биты. d) 376832 бит в Кбайты. e) 4096 бит в Кбайты. f) 2,5 Мбайт в Кбайты
Ответы (1)
В каком варианте объёмы памяти расположены в порядке возрастания? 1) 5 бит, 3 байта, 20 бит, 1 Кбайт, 1010 байт 2) 5 бит, 3 байта, 20 бит, 1010 байт, 1 Кбайт 3) 5 бит, 20 бит, 3 байта, 1 Кбайт, 1010 байт 4) 5 бит, 20 бит, 3 байта, 1010 байт, 1 Кбайт
Ответы (1)
Укажите упорядоченную по возрастанию последовательность значений Выберите один ответ: 1. 20 бит, 2 байта, 15 бит 2. 2 байта, 15 бит, 20 бит 3. 15 бит, 2 байта, 20 бит 4. 15 бит, 20 бит, 2 байта
Ответы (1)
Сколько кбайт содержит сообщение объемом в 2^17 бит сколько кбайт содержит 2^13 бит сколько кбайт содержит2^16 бит сколько кбайт содержит2^15 бит сколько кбайт содержит2^14 бит сколько бит информации содержит 1/4 кбайт сколько мбайт содердит 2^28
Ответы (1)
Выберите вариант, в котором объемы памяти расположены в порядке возрастания a. 15 бит, 20 бит, 2 байта, 1 Кбайт, 1010 байт b. 15 бит, 2 байта, 20 бит, 1 Кбайт, 1010 байт c. 15 бит, 20 бит, 2 байта, 1010 байт, 1 Кбайт d.
Ответы (1)