Задать вопрос
6 января, 16:02

Program z6_2;

uses crt;

const n=6;

var a:array[1 ... 6]of real;

i:integer;

begin

clrscr;

Writeln ('введите элемент массива') ;

for i:=1 to 6 do readln (a[i]) ;

if min min:=a[i];

writeln ('min=', min:7:3) ;

Repeat until keypressed;

end.

Подскажите где ошибка В Pascal

Текст: Составить программу, которая выводит на экран минимальный элемент массива Х и его индекс Х={1, 3, 5, 2, - 12, 0}.

+1
Ответы (1)
  1. 6 января, 17:31
    0
    Uses crt;

    var a: array[1 ... 6]of integer;

    i, min: integer;

    begin

    clrscr;

    min : = maxInt;

    Writeln ('введите элементы массива') ;

    for i : = 1 to 6 do

    begin

    readln (a[i]) ;

    if (min > a[i]) then min : = a[i];

    end;

    writeln ('min=', min) ;

    repeat until keypressed;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Program z6_2; uses crt; const n=6; var a:array[1 ... 6]of real; i:integer; begin clrscr; Writeln ('введите элемент массива') ; for i:=1 to ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Program naim4; var a, b, c, d, min:real; begin; writeln ('введите 4 числа') ; readln; min:=a; if b < min then min:=b; if c < min then min:=c; if d < min then min:=d; writeln ('минимальное ', min) ; readln; end.
Ответы (2)
Выдаёт ошибку: операнды имеют неприводимые типы. Где я ошиблась? (Программа написана на языке Pascal ABC) Program Home; Uses CRT; Var a: integer; b: real; Begin WriteLn ('Введите еденицу измереня: килограмм, миллиграмм, грамм, тонна, центнер') ;
Ответы (1)
Исправить ошибки в паскале program exp3; const m=5; n=3; type matr = array [1 ... m, 1 ... n] of integer; var m: matr; b, i, j, k : integer; повторно объявленный идентификатор begin clrscr; randomize;
Ответы (1)
Program a2; var n, i, min, max, x:integer; begin Writeln ('Введите колицество человек в классе:') ; Readln (n) ; Writeln ('Введите рост 1 ученика:') ; readln (x) ; min:=x; max:=x; for i:=2 to n do begin Writeln ('Введите рост ', i,' ученика:') ;
Ответы (1)
Помогите найти ошибку в программе (Массив) Program Ah; uses crt; var A:array[1 ... 15] of integer; i, k, n:integer; begin clrscr; for i:=1 to 18 do begin writeln ('A[', i,']=') ; read (A[i]) ; end; writeln ('Введите число') ; read (n) ; k:=0;
Ответы (1)