Задать вопрос
28 октября, 18:24

Найдите количество целых чисел на

интервале [100; 25000], у которых сумма цифр в десятичной и пятеричной системах счисления одинаковые. В ответе укажите целое число без пробелов и знаков препинания, например, 19

+4
Ответы (1)
  1. 28 октября, 20:26
    0
    Var a, b: array [100 ... 25000] of integer;

    i, k, n, p:integer;

    Begin

    for i:=100 to 25000 do

    begin

    b[i]:=i;

    a[i]:=i;

    n:=0;

    while a[i]>0 do

    begin

    n:=n + (a[i] mod 10) ;

    a[i]:=a[i]div 10;

    end;

    p:=0;

    while b[i]>0 do

    begin

    p:=p + (b[i] mod 5)

    ; b[i]:=b[i]div 5;

    end;

    if (n=p) then inc (k) ;

    end;

    writeln (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найдите количество целых чисел на интервале [100; 25000], у которых сумма цифр в десятичной и пятеричной системах счисления одинаковые. В ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Десятичное число 4563 в двоичной системе счисления равно 2) Десятичное число 800 в восьмеричной системе счисления равно 3) Десятичное число 781 в шестнадцатеричной системе счисления равно 4) Двоичное число 1000000 в десятичной системе счисления
Ответы (1)
На интервале [1:1000] надо найти количество чисел, у которых сумма цифр в десятичной и троичной системе счисления совпадают. Ответ записать в десятичной системе счисления. В ответе укажите только число без единиц измерения.
Ответы (1)
Даны три числа 33, 66, 88 в различных системах счисления. К этим числам прибавили по единице и получили во всех системах счисления 100. Найти зна- чения всех этих чисел в десятичной системе счисления.
Ответы (1)
Запись числа 100 а) отсутствует в двоичной системе счисления; б) существует в двоичной, десятичной, восьмиpичной и шестнадцатеpичной системах счисления; в) отсутствует в десятичной системе счисления; г) отсутствует в восьмеpичной системе счисления.
Ответы (2)
1.11010101,00011 переведите число из двоичной в десятичную систему счисления 2.10111101,110111 переведите число из двоичной в восьмиричную систему счисления 3.101100010100,1011 переведите число из двоичной в шестнадцатиричную систему счисления 4.
Ответы (1)