Задать вопрос
6 июня, 12:30

Даны два неравных целых двухзначных числа. Возвести в квадрат большее из этих чисел и удвоить меньшее число. Написать программу для паскаль.

+4
Ответы (1)
  1. 6 июня, 16:26
    0
    Это решение при задании вручную этих чисел:

    Program sadadasf;

    var i, k, l: integer;

    begin

    Writeln ('Введите первое целое двухзначное число:') ;

    readln (i) ;

    Writeln ('Введите второе целое двухзначное число:') ;

    readln (k) ;

    If k>i then begin

    k:=k*k;

    i:=i*2;

    end;

    If i>k then begin

    i:=i*i;

    k:=k*2;

    end;

    Writeln ('Первое число:', i) ;

    Writeln ('Второе число:', k) ;

    end.

    Это решение при задании чисел в самой программе:

    Program sadadasf;

    var i, k, l: integer;

    begin

    i:=5;

    k:=3;

    If k>i then begin

    k:=k*k;

    i:=i*2;

    end;

    If i>k then begin

    i:=i*i;

    k:=k*2;

    end;

    Writeln ('Первое число:', i) ;

    Writeln ('Второе число:', k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны два неравных целых двухзначных числа. Возвести в квадрат большее из этих чисел и удвоить меньшее число. Написать программу для паскаль. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы