Задать вопрос
24 сентября, 19:15

Напишите программу в паскале.

Грузовой автомобиль выехал из одного города в другой со скоростью v1 км/ч

Через t ч в этом же направлении выехал легковой автомобиль со скоростью v2 км/ч. составить программу, определяющею, догонит легковой автомобиль грузовой через t1 х после своего выезда

+1
Ответы (1)
  1. 24 сентября, 21:57
    0
    const

    v1 = 5; / / Скорость грузовика

    v2 = 10; //Скорость легкового автомобиля

    t = 5; / / Задержка между выездом

    var

    t1 : integer; / / Время, от выезда легкового авто

    begin

    readln (t1) ;

    if v1 * (t + t1) < = v2 * t1 then

    writeln ('Догонит')

    else writeln ('Не догонит') ;

    end.

    { Уравнение зависимости координаты от времени

    x = xo + vt

    x0 = 0

    xg (t) = v1 * (t+t1)

    xl (t) = v2*t1

    xl (t) > = xg (t) }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу в паскале. Грузовой автомобиль выехал из одного города в другой со скоростью v1 км/ч Через t ч в этом же направлении ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Грузовой автомобиль выехал из одного города в другой со скоростью V1 км/ч. Через t в этом же направление выехал легковой автомобиль со скоростью v2 км/ч. Догонит ли легковой автомобиль грузовой через t1 записав это в программе Turbo Pascal
Ответы (1)
Как составить программу? составьте программу, определяющею, является ли последняя цифра введенного целого числа нечетным числом?
Ответы (1)
Легковой автомобиль проехал 57,12510 км, а грузовой автомобиль - 111000,12 км. Какой автомобиль проехал большее расстояние? Выберите один ответ: легковой грузовой
Ответы (1)
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
Создать на Паскале форму. 1. Население некоторой страны в 1904 году составляло а человек. По переписи населения, проведенной в прошлом году, зарегистрировано b человек. Составить программу вычисления среднегодового прироста населения за этот период.
Ответы (1)