Задать вопрос
11 мая, 15:58

1. Дано целое

число А. Определить количество цифр в числе, которые больше 6.

2. Сумма в А

руб. лежит на расчетном счету. На сумму начисляется в% каждый год

прибыли. Прибыль со счета не снимается. Через сколько лет данная сумма

удвоится.

+5
Ответы (1)
  1. 11 мая, 16:19
    0
    Program zz;

    var n, x, a:integer;

    begin

    readln (a) ;

    while a>0 do

    begin

    x:=a mod 10;

    if x<6 then n:=n+1;

    a:=a div 10;

    end;

    writeln (n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Дано целое число А. Определить количество цифр в числе, которые больше 6. 2. Сумма в А руб. лежит на расчетном счету. На сумму ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
1. Дано двузначное число. Определить: a. какая из его цифр больше, первая или вторая; b. одинаковы ли его цифры. 2. Дано двухзначное число. Определить, равен ли квадрат этого числа учетверённой сумме кубов его цифр.
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Авиакомпания перевезла в первый год 21 тыс. пассажиров. Каждый следующий год увеличила перевозки на 4%. Сколько тыс. пассажиров перевезено за 5 лет? Через сколько лет удвоится пассажиропоток. Помогите с задаче по информатике, напишите программу.
Ответы (1)