Задать вопрос
13 марта, 18:38

Pascal ABC:

Дана последовательность чисел, среди которых имеется несколько нулей. Вывести на печать (построчно) числа стоящие до 1-го нуля и числа стоящие между нулями.

пример:

входные данные

10

1 0 1 2 3 0 15 4 0 7

выходные данные

1

1 2 3

15 4

+1
Ответы (1)
  1. 13 марта, 19:15
    0
    Const

    n = 50; {Максимальное количество чисел в последовательности}

    t = - 77; {Число-ограничитель, означающее конец ввода}

    type

    ta = array[1 ... n] of integer;

    var

    a: ta; {массив членов последовательности}

    az: ta; {массив, содержащий номера нулей в последовательности}

    kz: integer; {количество членов в массиве az}

    i, iz, p, n1, n2: integer;

    flag: boolean;

    begin

    {Вводим числа и сразу же отслеживаем номера нулей в последовательности}

    Writeln ('Вводите последовательность чисел, окончание ввода по - 77') ;

    i : = 0; iz : = 0;

    repeat

    Read (p) ;

    if p t then begin

    i : = i + 1;

    a[i] : = p;

    if p = 0 then begin

    iz : = iz + 1;

    az[iz] : = i;

    end

    end

    until p = t;

    kz : = iz;

    Writeln ('Вывод последовательностей') ;

    {1. До первого встреченного нуля}

    for i : = 1 to az[1] - 1 do Write (a[i], ' ') ;

    Writeln;

    {2. Остальные промежутки}

    for iz : = 1 to kz do

    begin

    for i : = az[iz] + 1 to az[iz + 1] - 1 do Write (a[i], ' ') ;

    Writeln;

    end

    end.

    Тестовое решение:

    Вводите последовательность чисел, окончание ввода по - 77

    1 2 3 0 5 6 7 0 0 10 11 12 13 0 15 16 17 18 19 20 - 77

    Вывод последовательностей

    1 2 3

    5 6 7

    10 11 12 13
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Pascal ABC: Дана последовательность чисел, среди которых имеется несколько нулей. Вывести на печать (построчно) числа стоящие до 1-го нуля ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Входные данные Вводится натуральное число N, которое не превосходит 30. Выходные данные Вычислите 1+2+22+23+ ...+2 N. Примеры входные данные 1 выходные данные 3 входные данные 4 выходные данные 31
Ответы (1)
Дано натуральное число N. Напишите функцию (Pascal), определяющую количество нулей среди всех цифр числа N. Входные данные Задано единственное число N Выходные данные Необходимо вывести количество нулей среди всех цифр числа N.
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)