Задать вопрос
4 мая, 09:37

Найти алгоритм решения задачи и реализовать его с помощью оператора (операторов) if-then-else. В Атлантическом океане терпит бедствие пассажирский теплоход "Посудина". Все пассажиры будут спасены, если на помощь успеют два судна. Судно продержится на плаву t часов. Скорость судов-спасателей 40 узлов. Составить программу, определяющую спасутся ли пассажиры. Известны расстояния от трех судов-спасателей до тонущего судна.

+4
Ответы (1)
  1. 4 мая, 10:17
    0
    Const

    v=40;

    var

    t, r1, r2, r3:real;

    n:integer;

    begin

    write ('Сколько часов продержатся пассажиры? ') ;

    readln (t) ;

    write ('Введите расстояния до трех спасателей (в узлах) : ') ;

    readln (r1, r2, r3) ;

    if r1/v
    if r2/v
    if r3/v
    If n>1 then writeln ('Спасутся все')

    else

    if n>0 then writeln ('Спасется половина пассажиров')

    else writeln ('Никто не спасется')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти алгоритм решения задачи и реализовать его с помощью оператора (операторов) if-then-else. В Атлантическом океане терпит бедствие ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике