Задать вопрос
16 июня, 07:16

Дан номер года. Определить количество дней в этом году, если високосный год делится на 4, за исключением тех годов, которые делятся на 100 и не делятся на

400. Решить нужно с помощью case.

+3
Ответы (1)
  1. 16 июня, 09:10
    0
    Program gt;

    var n:longint;

    begin

    readln (n) ;

    case n of

    1 ... 10000: if (n mod 400=0) or ((n mod 4=0) and (n mod 1000)) then writeln ('YEs') else

    writeln ('NO') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан номер года. Определить количество дней в этом году, если високосный год делится на 4, за исключением тех годов, которые делятся на 100 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Определить количество дней в году, которое вводится пользователем. Алгоритм решения задачи: В високосном году - 366 дней, в обычном 365. Високосными годами являются все года.
Ответы (1)
На с + + Дан номер года. Требуется определить количество дней в этом году, учитывая, что обычный год насчитывает 365 дней, а високосный - - 366 дней.
Ответы (1)
Дан номер года. Определить, является ли он високосным (год является високосным, если его номер делится на 4, за исключением тех, которые делятся на 100 и не делятся на 400).
Ответы (2)
Написать программу, определяющую количество дней в месяце Алгоритм решения задачи: Переменная d имеет тип данных запись и содержит два поля: year - для хранения года и month - для месяца. Пользователь вводит год и месяц.
Ответы (1)
Задание 1. Ввести номер месяца и вывести количество дней в нем, а также число ошибок при вводе. Пример: Введите номер месяца: -2 Введите номер месяца: 11 В этом месяце 30 дней. Вы вводили неверно 1 раз. Задание 2.
Ответы (1)