Задать вопрос
10 августа, 12:49

Напишите программу в PascalAbc которая на вход получает 3 вещественных числа и выводит на экран большее из них.

+4
Ответы (1)
  1. 10 августа, 14:43
    0
    Var

    x, y, z:real;

    begin

    writeln ('Введите три числа') ;

    read (x, y, z) ;

    If (x>z) and (x>y) then

    writeln ('Наибольшее = ', x) ;

    If (y>z) and (y>x) then

    writeln ('Наибольшее = ', y) ;

    If (z>x) and (z>y) then

    writeln ('Наибольшее = ', z) ;

    If (z=y) and (y=x) then writeln ('Все числа одинаковые') else

    begin

    If (z=x) then writeln ('числа x и z равны') ;

    If (y=x) then writeln ('числа x и y равны') ;

    If (z=y) then writeln ('числа y и z равны') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу в PascalAbc которая на вход получает 3 вещественных числа и выводит на экран большее из них. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Написать программу, которая выводит на экран сумму средних арифметических значений двух вещественных массивов из 10 элементов. 2. Написать прогрумму, которая выводит на экран, разность значений двух вещественных массивов из 10 элементов.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b). Входные данные Входная строка содержит два вещественных числа a и b, разделённых пробелом.
Ответы (1)
В питоне Напишите программу, которая вводит два вещественных числа, a и b (a < b), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a, b).
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)