Задать вопрос
27 октября, 16:25

Задан вид квадратного уравнения ах квадрат + bx+c=0, коэффициенты a, b, c. Найти корни уравнения x1, x2.

1. Разработать схему алгоритма программы

2. Составить программу на языке Паскаль по разработанному алгоритму

+4
Ответы (1)
  1. 27 октября, 18:18
    0
    Var a, b, c, d, x1, x2:real;

    begin

    writeln ('Решение квадратных уравнений') ;

    writeln ('') ;

    writeln ('Введите коэффициенты a, b, c:') ;

    readln (a, b, c) ;

    d:=sqr (b) - 4*a*c;

    if d<0 then writeln ('Корней нет') ;

    if d=0 then begin x1:=-b / (2*a) ;

    writeln ('Один корень:') ;

    writeln (x1:4:2) ;

    end;

    if d>0 then begin

    x1:=-b+sqrt (d) / (2*a) ;

    x2:=-b-sqrt (d) / (2*a) ;

    writeln ('Корни уравнения:') ;

    writeln (x1:4:2) ;

    writeln (x2:4:2) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задан вид квадратного уравнения ах квадрат + bx+c=0, коэффициенты a, b, c. Найти корни уравнения x1, x2. 1. Разработать схему алгоритма ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) приведите пример исполнителя алгоритма. 2) Должен ли составитель алгоритма знать, кто будет являться исполнителем алгоритма? 3) Перечислите свойства алгоритма. 4) Поясните значение свойства алгоритма "определенность".
Ответы (1)
1. Разработать схему алгоритма, который вводит массив из Nцелых чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел. 2.
Ответы (2)
Какие программы относятся к прикладным программам? A. Программы общего назначения. B. Специальные профессиональные программы. C. Языки программирования. D. Сервисные программы. E. Операционные системы.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Антивирусные программы-это 1. программы сканирования и распознавания 2. программы выявляющие и лечащие компьютерные вирусы 3. программы только выявляющие вирусы 4. программы-архиваторы разархиваторы
Ответы (1)