Задать вопрос
3 декабря, 21:53

Датчиком случайных чисел сгенерируйте случайное натуральное число в интервале от 1 до 900. Определите, сколько цифр в полученном числе.

+1
Ответы (1)
  1. 4 декабря, 00:47
    0
    Var

    n: integer;

    s: string;

    begin

    Randomize;

    n : = Random (900) + 1;

    Str (n, s) ;

    writeln ('Количество цифр в числе ', n, ' равно ', length (s))

    end.

    Тестовое решение:

    Количество цифр в числе 598 равно 3
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Датчиком случайных чисел сгенерируйте случайное натуральное число в интервале от 1 до 900. Определите, сколько цифр в полученном числе. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Заполнить массив А (13) датчиком случайных чисел в интервале от 0 до 40 определить количество элементов массива не превосходящих по величине число В число В задается датчиком случайных чисел в интервале от 0 до 20
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
Помогите решить задачу на массивы, любую! 1. Найти сумму элементов в каждом столбике массива MxN, элементы которого задаются датчиком случайных чисел на интервале [-19; 20] 2.
Ответы (1)
Найти средне арифметическое элементов последовательности, превосходящих некоторое число С. Массив задан датчиком случайных чисел на интервале [-44, 35]. Размер произвольный. Значение С вводится с экрана.
Ответы (1)
Массив задан датчиком случайных чисел на интервале [-37, 66]. Найти наименьший нечетный элемент. Размер произвольный.
Ответы (1)