Задать вопрос
27 октября, 04:47

Записать программу формирования и выведения масива А розмером N, который

содержит N первых элементов последовательности чисел Фибоначчи

+3
Ответы (1)
  1. 27 октября, 06:56
    0
    const

    n = 10;

    var

    a: array [1 ... n] of integer;

    begin

    a[1] : = 1;

    a[2] : = 2;

    write ('1 2 ') ;

    for i: integer : = 3 to n do

    begin

    a[i] : = a[i - 2] + a[i - 1];

    write (a[i], ' ') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Записать программу формирования и выведения масива А розмером N, который содержит N первых элементов последовательности чисел Фибоначчи ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачу на Паскале. Числа Фибоначчи определяются как а (0) = 1, а (1) = 1, а (i) = a (i-1) + a (i-2). Найти десятое число Фибоначчи. Найти : a) N-ое число Фибоначчи б) Сумму первых N чисел Фибоначчи
Ответы (1)
Составить программу для ввода десяти элементов масива и подстета суммы отрицательных чисел масива
Ответы (1)
Дата рождения. Профессор Бит Байтович Алгоритмович черезвычайно гордится своим гениальным, по его мнению сыном.
Ответы (1)
Последовательность Фибоначчи определяется следующим образом: первые два члена последовательности равны 1, а каждый следующий равен сумме двух предыдущих. То есть числами Фибоначчи являются 1,1,2,3,5,8,13, ... Вводится натуральное число.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)