Задать вопрос
8 февраля, 14:37

Ваш друг предлагает вам переписать отснятый им видеофильм. Из носителей информации у вас есть: компакт-диск объемом 650 МБ, дискета объемом 1 МБ и флеш-накопитель объемом 1000 Мб. Напишите программу, перечисляющую все носители, на которые полностью поместится фильм. Объем видеофайла задается в мегабайтах.

+3
Ответы (1)
  1. 8 февраля, 16:43
    0
    Var

    d:integer;

    const

    a=650;

    b=1;

    c=1000;

    begin

    write ('Введите объём видеофайла в мегабайтах: ') ;

    readln (d) ;

    if d>a then write ('Видеофайл не помещается на носитель информации"А"!',#10) else

    writeln ('Памяти хватает для записи на носитель "А"! ',#10) ;

    if d>b then write ('Видеофайл не помещается на носитель информации"B"!',#10) else

    writeln ('Памяти хватает для записи на носитель "B"! ',#10) ;

    if d>c then write ('Видеофайл не помещается на данный носитель информации"С"!',#10) else

    writeln ('Памяти хватает для записи на носитель "C"! ',#10) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Ваш друг предлагает вам переписать отснятый им видеофильм. Из носителей информации у вас есть: компакт-диск объемом 650 МБ, дискета объемом ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Какое устройство для хранения данных имеет больший объём -дискета - DVD-диск -флеш - накопитель -СD-диск -жёсткий диск
Ответы (2)
Расположите носители информации по возрастанию максимального объема информации, которая может быть на них записана 1 hd dvd-диск 2 cd-диск 3 dvd-диск 4 дискета 5 blu-ray-диск
Ответы (1)
USB флеш-накопитель имеет объём 4 Гбайт. Рукопись автора содержит 2048 страниц. На каждой странице 512 строк, в каждой строке 256 символов. Каждый символ кодируется 16 битами. Кроме того, рукопись содержит 920 картинок объёмом 4 Мбайт каждая.
Ответы (1)
Перечислите съемные носители информации: 1) Дискета 2) Флеш-карта 3) Usb-флешь-накопитель 4) CD-RW 5) Оперативная память
Ответы (1)
Какие из нижеперечисленных устройств используются для длительного хранения информации и х должно быть три 1. Магнитный диск 2. Оперативная память 3. флеш-накопитель 4. процессор 5. компакт диск 6. монитор
Ответы (1)