Задать вопрос
24 сентября, 12:41

Написать программу которая из двух строк составляет третью, путём чередования символов первой и второй строки.

+2
Ответы (1)
  1. 24 сентября, 12:57
    0
    program tref;

    var a1, a2, a3:string; i, c, b, j, a:integer;

    begin

    a:=1;

    b:=1;

    readln (a1) ;

    readln (a2) ;

    a3:=a1+a2; for i:=1 to length (a1) * 2 do

    begin

    if (i mod 2 = 1) then

    begin

    a3[i]:=a1[b];

    b:=b+1; end;;

    if (i mod 2 = 0) then

    begin

    a3[i]:=a2[a];

    a:=a+1;

    end;

    end;

    writeln (a3) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу которая из двух строк составляет третью, путём чередования символов первой и второй строки. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Сколько символов в тексте, если 1) Сколько символов в тексте, если мощность алфавита-64 символа, а объем информации, содержащийся в нем-1,5 Кбайт. 2) Сообщение занимает 3 страницы по 25 строк. В каждой строке записано по 60 символов.
Ответы (1)
1. Приветствие участникам олимпиады от лунных человечков записано с помощью всех символов лунного алфавита: ЮМА_ЮМ. Сколько информации оно несет? 2. Сообщение занимает 6 страниц по 35 строк. В каждой строке записано по 50 символов.
Ответы (2)
1) N=32 символа, 7 стр. по 40 строк по50 символов I-? 2) I=2,5 кб К=2560 символов N-? 3) N=256 символов 5 стр. по 30 строк по 70 символов I-? Ответ байтах
Ответы (1)
Сообщение на языке Хинь (50 символов в алфавите) занимает 5 страниц, по 30 строк на странице и по 60 символов в строке. Сообщение на языке Хань (70 символов в алфавите) занимает 4 страницы по 25 строк, 70 символов в строке.
Ответы (1)
Злой хакер хочет испортить программное обеспечение на 40 компьютерах компании. На каждом компьютере 37 программ, каждая из которых состоит из 9000 строк кода.
Ответы (2)