Задать вопрос
22 апреля, 04:24

Составить программу на языке паскаль

задание: дана матрица А (N, N). Составить программу подсчета количества положительных элементов, расположенных выше главной диагонали

+4
Ответы (1)
  1. 22 апреля, 04:39
    0
    Var n, i, j, ans : integer;

    a : array[,] of integer;

    begin

    read (n) ;

    ans : = 0;

    SetLength (a, n + 1, n + 1) ;

    for i : = 1 to n do

    for j : = 1 to n do

    read (a[i, j]) ;

    for i : = 1 to n do

    for j : = i + 1 to n do

    if (a[i, j] > 0) then

    ans : = ans + 1;

    writeln (ans) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу на языке паскаль задание: дана матрица А (N, N). Составить программу подсчета количества положительных элементов, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы