Задать вопрос
9 июля, 14:43

Написать программу, ведущую учет очков, набранных каждой командой при игре в баскетбол. Количество очков, полученных командами в ходе игры, может быть равно 1, 2 или 3. После окончания игры выдать итоговое сообщение и указать номер команды-победительницы. Окончание игры условно моделировать вводом количества очков, равного нулю. На паскаль

+3
Ответы (2)
  1. 9 июля, 15:30
    0
    Полный код не влез, в 2 комента вставил
  2. 9 июля, 16:00
    0
    var

    commands: array [1 ... 2] of byte;

    buf: string;

    begin

    writeln ('Формат ввода: (№ комманды) (пробел) (очки) ') ;

    writeln ('Например: 1 3') ;

    writeln ('№ О') ;

    repeat

    readln (buf) ;

    if buf = '0' then break;

    commands[integer. Parse (buf[1]) ] + = byte. Parse (buf[3]) ;

    until false;

    writeln (String. Format ('Команда {0} победила во счётом {1} очк.', commands[1] > commands[2]? 1 : 2, max (commands[1], commands[2]))) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, ведущую учет очков, набранных каждой командой при игре в баскетбол. Количество очков, полученных командами в ходе игры, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Даны 20 пар однозначных чисел. Первое число каждой пары означает количество мячей, забитых футбольной командой в игре, второе - количество пропущенных мячей в этой же игре.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Известно кол-во очков, набранных футбольными командами в чемпионате. Какая команда (определить ее номер) набрала наименьшее кол-во очков? Если таких команд несколько, то должна быть найдена первая из них.
Ответы (1)
Написать программу подведения итогов олимпийских игр, программу пользователь должен ввести кол-во медалей разного достоинства заваёваной каждой командой участниц, а программа должна посчитать общее число медалей и соотвествующие число очков, после
Ответы (1)
В классе 35 учеников, каждый из которых любит футбол, волейбол или баскетбол. 24 из них любят футбол, 18 - волейбол, 12 - баскетбол. Кроме того, 10 учеников одновременно любят и футбол и волейбол, 8 - футбол и баскетбол, а 5 - волейбол и баскетбол.
Ответы (1)