Задать вопрос
13 июля, 11:37

Дано 4-х значное число,

найти что больше произведение сотен и десятков

или произведение тысяч и единиц

+5
Ответы (1)
  1. 13 июля, 13:43
    0
    Var n:integer;

    pro, sum:integer;

    begin

    write ('Введите число: ') ; readln (n) ;

    pro:=1; sum:=0;

    while n>0 do

    begin

    pro:=pro * (n mod 10) ;

    sum:=sum + (n mod 10) ;

    n:=n div 10;

    end;

    writeln ('Произведение = ', pro) ;

    writeln ('Сумма = ', sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано 4-х значное число, найти что больше произведение сотен и десятков или произведение тысяч и единиц ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
2) Вводится четырехзначное число с клавиатуры. Определить цифру тысяч, сотен, десятков и единиц. В окне вывода должно быть так (это пример) Введи четырехзначное число: 1234 цифра тысяч-1 цифра сотен-2 цифра десятков-3 цифра единиц - 4
Ответы (1)
Вводится четырехзначное число с клавиатуры. Определить цифру тысяч, сотен, десятков и единиц. В окне вывода должно быть так (это пример) Введи четырехзначное число: 1234 цифра тысяч-1 цифра сотен-2 цифра десятков-3 цифра единиц - 4
Ответы (1)
Напишите программу на паскале, которая 1) сначала определит по введенному двузначному числу цифру десятков и цифру единиц. 2.1) Если цифра десятков меньше цифры единиц, то программа выведет двузначное число, состоящее из. цифр единиц.
Ответы (1)
1. Дано трехзначное число. Найти число единиц в нем число десятков в нем сумму его цифр произведение его цифр 2. Дано трехзначное число. Найти число. Найти число, полученное при прочтении его цифр справа налево
Ответы (1)
Дано трехзначное число. Найти число единиц в нем, число десятков в нем, число сотен в нем, сумму его цифр, произведение его цифр
Ответы (1)