Задать вопрос
24 июня, 17:35

Разработать алгоритм, программу и тест. Дана последовательность из 50-ти чисел. Определить есть ли в последовательности числа кратные заданному с клавиатуры числу С.

+2
Ответы (1)
  1. 24 июня, 20:05
    0
    Const n=50;

    Var a, k:array[1 ... n] of integer;

    i, c:integer;

    Begin

    Randomize;

    Writeln ('Введите число c: ') ;

    Readln (c) ;

    For i:=1 to n do

    begin

    A[i]:=Random (10) ;

    Write (i,' ') ;

    end;

    Writeln;

    For i:=1 to n do

    Begin

    If a[i] mod c=0 then

    Begin

    Write (a[i],' ') ;

    end;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Разработать алгоритм, программу и тест. Дана последовательность из 50-ти чисел. Определить есть ли в последовательности числа кратные ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
1. Разработать схему алгоритма, который вводит массив из Nцелых чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел. 2.
Ответы (2)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)
Дана последовательность чисел, вводимых с клавиатуры и оканчивающаяся нулем. Составьте программу вычисления: a. суммы всех чисел последовательности; b. среднего арифметического всех чисел последовательности: c.
Ответы (1)
1. Разработать программу алгоритма для подсчета количества отрицательных чисел среди целых чисел a, b, c. Протестировать алгоритм для всех возможных случаев (когда количество отрицательных чисел равно 0, 1, 2 и 3). 2.
Ответы (1)