Задать вопрос
9 апреля, 06:29

Написать фрагмент программы, выводящей на экран номера отрицательных элементов массива

+4
Ответы (1)
  1. 9 апреля, 09:18
    0
    Const n=10;

    Var a, b:array[1 ... n] of integer;

    i:integer;

    Begin

    Randomize;

    For i:=1 to n do

    begin

    A[i]:=Random (20) - 10;

    Write (a[i],' ') ;

    end;

    Writeln;

    Writeln ('Отрицательные элементы массива: ') ;

    For i:=1 to n do

    Begin

    If A[i]<0 then

    Begin

    b[i]:=a[i];

    Write (b[i],' ') ;

    end;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать фрагмент программы, выводящей на экран номера отрицательных элементов массива ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
Что определяет для массива X[1 ... n] следующий алгоритм P: = 0; For k: = 1 to n do If X[k]
Ответы (1)