Задать вопрос
29 августа, 23:16

Найти остаток от деления целой части значения функции z=In (x^2+ab) на 7 и, в зависимости от его величины, напечатать сообщение об одном из дней недели, пронумеровав их от 0 до 6. Решить в Паскаль

+4
Ответы (1)
  1. 30 августа, 02:37
    0
    Var a, b, x: real; z: integer;

    begin

    write ('x = ') ; readln (x) ;

    write ('a = ') ; readln (a) ;

    write ('b = ') ; readln (b) ;

    z : = Trunc (x*x+a*b) ;

    writeln ('[z] = ', z) ;

    writeln ('[z] mod 7 = ', z mod 7) ;

    writeln (System. Globalization

    . CultureInfo. CurrentCulture

    . DateTimeFormat. DayNames[ (z+1) mod 7]) ;

    / / Если нулевой день это Воскресенье, то не (z+1) а z mod 7

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти остаток от деления целой части значения функции z=In (x^2+ab) на 7 и, в зависимости от его величины, напечатать сообщение об одном из ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Найти остаток от деления целой части значения функции y = ln (x²+ab) на 7 и, в зависимости от его величины, напечатать сообщение об одном из дней недели, пронумеровав их от 0 до 6.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Составить программу, которая находит минимальное натуральное число х, такое, что остаток от деления х на 10 равен 9, остаток от деления х на 9 равен 8, остаток от деления х на 8 равен 7, ... остаток от деления х на 2 равен 1.
Ответы (1)
Автомат получает на вход нечётное число X. По этому числу строится трёхзначное число Y по следующим правилам. 1. Первая цифра числа Y (разряд сотен) - остаток от деления X на 4. 2. Вторая цифра числа Y (разряд десятков) - остаток от деления X на 3.
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)