Задать вопрос
3 ноября, 14:43

Определите, количество чисел K, для которых следующая программа выведет такой же результат, что и для K = 22:

var i, k: integer;

function F (x:integer) : integer;

begin

F:=x*x*x+x*x;

end;

begin

i : = 20;

readln (K) ;

while (i > 0) and (F (i) > K) do

i:=i-1;

writeln (i) ;

end.

+3
Ответы (1)
  1. 3 ноября, 15:47
    0
    У тебя функция x^3+x^2 и перебор от 20 до 1, т. е. x^3+x^2 будет больше 22 при числах:

    20, 19, 18, 17, 16, 15, 14, 13, 12, 11, 10, 9, 8, 7, 6, 5, 4, 3.

    итого: 18 чисел
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определите, количество чисел K, для которых следующая программа выведет такой же результат, что и для K = 22: var i, k: integer; function F ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделать так чтобы Writeln был заменен другим словом и повторялься не больше двух раз program choise; var N_M:integer; writeln (' введи номер месяца ') ; readln (N_M) ; case N_M of 1:writeln (' январь ') ; 2:writeln (' февраль ') ;
Ответы (1)
Запиши программу в Паскале для вычисления площади прямоугольника со сторонами c и m. 1) begin writeln ('Введи длину и ширину прямоугольника c и m') ; readln (c, m) ; s:=c*m; writeln ('s=', s) ; readln; end.
Ответы (1)
Что выведет следующая программа? Объясните результат. program test; var a, b: integer; procedure p (Var x:integer; y:integer) ; begin x:=x+1; y:=x+y; end; begin a:=1; b:=2; p (a, b) ; writeln (a,' ', b) ; p (a, b) ; writeln (a,' ', b) ; readln; end.
Ответы (1)
Определите кол-во чисел K, для которых программа выведет такой же результат, что и для K=20; var i, k: integer; function F (x:integer) : integer; begin if x < 3 then F: = 1 else F: = F (x-1) + F (x-2) ; end; begin i: = 21; readln (K) ;
Ответы (1)
Объясните строчку (c:=10*c+a mod 10; a : = a div 10;) program pr36; function qwer (var a, b: integer) : integer; var c: integer; begin c:=0; while a > 0 do begin c:=10*c+a mod 10; a : = a div 10; end; qwer: = c; end; var a, b: integer;
Ответы (1)