Задать вопрос
12 апреля, 23:52

Задача

№1.

Написать программу решения уравнения

вида y=2x2+0,5z

Uses Crt;

Var y, x, z: real;

Begin

ClrScr;

Write ('Введите значения переменных x, z') ;

Read (x, z) ; {ввод значений через пробел}

y: = 2*x*x+0,5*z;

Writeln ('Результат вычислений y=', y) ;

End.

Задание

№ 2. Написать программу для решения уравнения

(спомощью стандартных арифметических функции) :

1. y=cos2x+sin3x

2. y=sin2π+π/2

3. y=tgx+0.25

4. y=|x|+2|z |

+1
Ответы (1)
  1. 13 апреля, 01:19
    0
    Задание 2, 1:

    program zadacha1;

    uses crt;

    var x, y: real;

    begin

    clrscr;

    write ('enter x: ') ;

    readln (x) ;

    x: = (x*pi) / 180; / / в Паскале используется измерение в радианах, здесь мы

    / / переводим из градусов (так как мы задаем значение в градусах) в радианы

    y:=sqr (cos (x)) + sqr (sin (x)) * sin (x) ;

    writeln ('y=', y:0:4) ;

    readkey;

    end.

    2

    program zadacha2;

    uses crt;

    var y: real;

    begin

    clrscr;

    y:=sqr (sin (pi)) + pi/2;

    writeln ('y=', y:0:4) ;

    readkey;

    end.

    3

    program zadacha3;

    uses crt;

    var x, y: real;

    begin

    clrscr;

    write ('enter x: ') ;

    readln (x) ;

    x: = (x*pi) / 180;

    y:=sin (x) / cos (x) + 0.25;

    writeln ('y=', y:0:4) ;

    readkey;

    end.

    4

    program zadacha4;

    uses crt;

    var x, y, z: integer;

    begin

    clrscr;

    write ('enter x, z') ;

    readln (x, z) ;

    y:=abs (x) + 2*abs (z) ;

    writeln ('y=', y:0:4) ;

    readkey;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача №1. Написать программу решения уравнения вида y=2x2+0,5z Uses Crt; Var y, x, z: real; Begin ClrScr; Write ('Введите значения ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделать так чтобы Writeln был заменен другим словом и повторялься не больше двух раз program choise; var N_M:integer; writeln (' введи номер месяца ') ; readln (N_M) ; case N_M of 1:writeln (' январь ') ; 2:writeln (' февраль ') ;
Ответы (1)
Как их сделать вместе чтобы работало Uses crt; var a, i:byte; s:real; begin clrscr; for i:=1 to 4 do begin writeln ('vvod') ; readln (a) ; if a mod 5=0 then writeln ('Число ', a,' кратно 5 ') else writeln ('Число ', a,' не кратно 5') end; end.
Ответы (1)
Выдаёт ошибку: операнды имеют неприводимые типы. Где я ошиблась? (Программа написана на языке Pascal ABC) Program Home; Uses CRT; Var a: integer; b: real; Begin WriteLn ('Введите еденицу измереня: килограмм, миллиграмм, грамм, тонна, центнер') ;
Ответы (1)
Помогите найти ошибку в программе (Массив) Program Ah; uses crt; var A:array[1 ... 15] of integer; i, k, n:integer; begin clrscr; for i:=1 to 18 do begin writeln ('A[', i,']=') ; read (A[i]) ; end; writeln ('Введите число') ; read (n) ; k:=0;
Ответы (1)
Где здесь ошибка program n_11; var a, b, c:Real; var d:Real; var x, x1, x2:Real; begin WriteLn ('Расширение квадратного уровнения') ; Write ('Введите коофиценты a, b, c >>') ; ReadLn (a, b, c,) ; d:=b*b-4*a*c;
Ответы (1)