Задать вопрос
17 февраля, 02:25

Напишите линейную программу, в результате выполнения которой целочисленные переменные x и y обмениваются значениями. При этом нельзя использовать дополнительные переменные.

+4
Ответы (1)
  1. 17 февраля, 04:03
    0
    Var

    x, y:Integer;

    Begin

    Read (x, y) ;

    x:=x+y;

    y:=x-y;

    x:=x-y;

    Writeln (x, ' ', y) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите линейную программу, в результате выполнения которой целочисленные переменные x и y обмениваются значениями. При этом нельзя ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Напишите линейную программу, в результате выполнения которой целочисленные переменные x и y обменяются значениями. При этом нельзя использовать дополнительные переменные.
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Помогите написать на паскале (Д) Заполнить массив из пятнадцати элементов случайным образом: а) вещественными значениями, лежащими в диапазоне от 0 до 1; б) вещественными значениями х (22 х < 23) ; в) вещественными значениями х (0 х < 10) ;
Ответы (1)
1. Какие значения примут переменные после выполнения следующих действий. d=50 g=5 t=d/g*3 a=d+g+t/4 t=a+d * (2+a) / 2 g=d+a+t/d 2 ... Какие значения примут переменные после выполнения следующих действий.
Ответы (1)