Задать вопрос
28 июня, 06:12

Написать программу на Free Pascal которая переводит число из десятичной системы в двоичную

+4
Ответы (1)
  1. 28 июня, 08:14
    0
    Function ToBinaryString (x: integer) : string;

    var r, s: string;

    begin

    if x < 0 then begin

    s : = '-';

    x : = - x;

    end;

    while x 0 do begin

    r : = Chr ((x and 1) or 48) + r;

    x : = x shr 1;

    end;

    ToBinaryString : = s + r;

    end;

    var x: integer;

    begin

    readln (x) ;

    writeln (ToBinaryString (x)) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на Free Pascal которая переводит число из десятичной системы в двоичную ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Переведите целые числа из десятичной системы в двоичную: 12, 523, 76, 121. 2. Переведите из десятичной системы счисления в восьмеричную: 856, 111, 98, 126. 3. Переведите из десятичной системы счисления в шестнадцатеричную: 907, 659, 124, 333.
Ответы (1)
1. Перевести число 11011100 из двоичной в десятичную, восьмеричную и шестнадцатеричную системы счисления 2. Перевести число 471 из восьмеричной в десятичную, двоичную и шестнадцатеричную системы счисления 3.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
1) Переведите число А2 из шестнадцатеричной системы в двоичную систему счисления. 2) Переведите число 143 из десятичной системы счисления в двоичную систему счисления.
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)