Задать вопрос
12 октября, 18:42

Вычислить произведение всех элементов одномерного массива В, в котором 20 элементов.

+4
Ответы (2)
  1. 12 октября, 19:38
    0
    Program pas;

    var b:array[1 ... 20] of integer;

    i, k: integer;

    begin

    k:=1;

    for i:=1 to 20 do

    readln (b[i]) ;

    for i:=1 to 20 do

    k:=k*b[i];

    writeln (k) ;

    end.
  2. 12 октября, 20:54
    0
    Const n=20;

    var B:array[1 ... n] of integer;

    i, s:integer;

    Begin

    Randomize;

    For i:=1 to n do

    Begin

    b[i]:=Random (10) ;

    Write (b[i],' ') ;

    end;

    s:=1;

    For i:=1 to n do

    Begin

    s:=s*b[i];

    end;

    writeln;

    Writeln ('Произведение элементов: ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вычислить произведение всех элементов одномерного массива В, в котором 20 элементов. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделать программу в Pascal. 1. Организуйте ввод и вывод одномерного массива в строку, в столбец. 2. Найдите произведение ненулевых элементов одномерного массива. 3.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Написать программу, позволяющую для заданного одномерного массива А из n вещественных или целых элементов реализовать обработку массива. Длина массива N задается пользователем как константное выражение.
Ответы (1)
Создать программу получения и обработки одномерного массива - вектора: Вычислить значения 35 элементов одномерного целочисленного массива F в интервале (-6, 10) с использованием генератора случайных чисел
Ответы (1)