Задать вопрос
4 сентября, 11:30

Помогите написать программу на паскале!

Создать файл а4, состоящий из 28 целых чисел. Найти среднее арифметическое всех чисел.

+3
Ответы (1)
  1. 4 сентября, 14:00
    0
    Program abc;

    var f: text; { Если не будет работать, то написать вместо "text" "file of longint" или еще что-нибудь другое.}

    x, y: longint;

    i: byte;

    begin

    y : = 0;

    assign (f, 'a4') ;

    reset (f) ;

    for i : = 1 to 28 do

    begin

    read (f, x) ;

    y : = y + x;

    end;

    writeln (y / 28) ;

    close (f) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать программу на паскале! Создать файл а4, состоящий из 28 целых чисел. Найти среднее арифметическое всех чисел. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите написать программу в Python. 1) Дан массив, состоящий из целых чисел. Нумерация элементов начинается с 0. Напишите программу, которая выведет элементы массива, номера которых четны (0, 2, 4 ...). 2) Дан массив, состоящий из целых чисел.
Ответы (1)
Почему файл, созданный в Word 2007, имеет расширение. docm? Вариант 1 файл предназначен для пересылки по электронной почте Вариант 2 файл содержит вирусы Вариант 3 файл создан на основе шаблона Вариант 4 файл содержит макросы
Ответы (1)
Сравнение файлов Первый файл на 1 мегабайт больше, чем второй файл. Второй файл на 3072 байта больше, чем третий файл. На сколько килобайт третий файл меньше, чем первый? В ответе укажите только число, слово "килобайт" писать не надо.
Ответы (1)
Фоксфорд олимпиада по информатикеПервый файл на 1 мегабайт больше, чем второй файл. Второй файл на 3072 байта больше, чем третий файл. На сколько килобайт третий файл меньше, чем первый? В ответе укажите только число, слово "килобайт" писать не надо.
Ответы (1)
Создать текстовый файл f1. Конкатенировать файл f 1 самого с собой, только записанного задом наперед и результат записать в файл f2. Вывести на экран файл f 2.
Ответы (1)