Задать вопрос
26 июля, 15:03

Определить, попадает ли точка с координатами x, y в круг радиусом r. Присвоить признаку N=1, если точка находится внутри круга, и N=0, если точка вне круга.

+1
Ответы (1)
  1. 26 июля, 18:46
    0
    Var x, y, r, n : integer;

    begin

    read (x, y, r) ;

    if ((x*x + y*y) < = (r*r)) then n : = 1 else n : = 0;

    writeln (n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определить, попадает ли точка с координатами x, y в круг радиусом r. Присвоить признаку N=1, если точка находится внутри круга, и N=0, если ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан алгоритм: Начало Присвоить a значение 1 Присвоить b значение 1 Присвоить c значение 0 Пока a меньше чем 1001 Начало цикла Присвоить b значение b * a Присвоить a значение a + 1 Конец цикла Пока b делится на 6 Начало цикла Присвоить c значение c +
Ответы (1)
Определить, попадает ли точка с координатами x0, y0 в круг радиусом r. Присвоить признаку N=1, если точка находится внутри круга, и N=0, если точка вне круга.
Ответы (1)
Нужно составить блок-схему по инф. задача: определить попадает ли точка М с координатами х, у в круг радиусом r с центром в начале координат.
Ответы (1)
Два игрока играют в игру. На координатной плоскости стоит фишка. Игроки ходят поочереди. В начале игры фишка находится в точке с координатами (4,2).
Ответы (1)
Дана программа, нужно написать код на паскале ABC Определить, попадает ли точка с координатами (x, y) в заштрихованную область. (заштрихованая область треугольник с координатами а (-3,0), в (3,0), с (0,2))
Ответы (1)