Задать вопрос
30 апреля, 23:25

Даны четыре натуральных числа. Просуммировать те из них, которые не содержат цифру 5

+5
Ответы (1)
  1. 1 мая, 02:50
    0
    Х)

    var

    i, k, b, a, sum: integer;

    begin

    for i : = 1 to 4 do

    begin

    readln (a) ;

    b : = a;

    k : = a;

    while (b > 0) do

    begin

    if (b mod 10 = 5) then

    begin

    k : = 0;

    end;

    b : = b div 10;

    end;

    sum : = sum + k;

    end;

    writeln (sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны четыре натуральных числа. Просуммировать те из них, которые не содержат цифру 5 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Числа Вам даны число N и цифра D. Выведите все N - значные числа, которые не содержат цифру D, в возрастающем порядке. Формат входных данных В единственной строке входного файла записаны число N (1 ≤ N ≤ 7) и цифра D (0 ≤ D ≤ 9).
Ответы (1)
Просуммировать элементы столбцов заданной матрицы размером 4*3. Результат получить в однородном массиве размером 3. (можно с подробным решением? добавить методические укащания к заданию?)
Ответы (1)
В ячейке А12 рассчитать максимальную плановую прибыль. имеется несколько наименований изделий. по каждому своя плановая прибыль. Исходя из задания (выделено жирным шрифтом) не могу понять: нужно просуммировать все ячейки, содержащие план.
Ответы (1)
На языке Си, не си + + Дан массив Х (324). Найти сумму элементов массива, предшествующих первому отрицательному элементу. Если среди элементов массива нет отрицательных, то просуммировать все элементы.
Ответы (1)
Дана целочисленная последовательность из 50 элементов. Элементы с черными номерами необходимо просуммировать и вывести среднее значение на экран.
Ответы (1)