Задать вопрос
31 декабря, 13:38

Составьте программу, которая позволяет ввести элементы массива а [1 ... 10] с клавиатуры и выводит на экран количество отрицательных элементов и их индексы.

+5
Ответы (1)
  1. 31 декабря, 14:06
    0
    Паскаль.

    var a:array [1 ... 10] of integer;

    begin

    writeln (' Введите 10 элементов массива через пробел') ;

    i:=1;

    repeat

    read (a[i]) ;

    i:=i+1;

    until i>10;

    k:=0;

    for i:=1 to 10 do

    if a[i]<0 then begin k:=k+1; write (i, ' ') ; end;

    writeln;

    if k=0 then write ('В массиве нет отрицательных элементов') else write ('В массиве ', k,' отрицательных элементов') ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу, которая позволяет ввести элементы массива а [1 ... 10] с клавиатуры и выводит на экран количество отрицательных ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Напишите программу, которая фармирует масси из N элементов (максимальное количество элементов равно 20), значения элементов массива - случайные числа от - 10 до 25 Программа должна: 1) выводить на экран сначала все элементы массива, стоящие на
Ответы (1)
1) ввести с клавиатуры массив из n элементов вывести на экран элементы меньшие среднего арифметического всех элементов массива 2) ввести с клавиатуры массив из n элементов вывести на экран максимальный четный элемент и минимальный нечетный элемент
Ответы (1)